Wordpress за обратным прокси IIS - сбрасывает соединение

Вопрос задан: 8 месяцев назад Последняя активность: 8 месяцев назад
up 0 down

У меня проблема с Wordpress и его запуском за обратным прокси. Я локализовал проблему, и это было решение вопроса, поставленного здесь: Изменение заголовков с помощью IIS7 Application Routing

До того, как я применил команду в принятом выше решении, я не смог посетить какие-либо ссылки на веб-сайте и получил слишком много ошибок перенаправлений. Включение опции сохранения исходного заголовка узла решило эти проблемы. Но сразу после того, как я больше не мог редактировать отдельные страницы, он не загружался и не возвращал ошибку ERR_CONNECTION_RESET.

Поскольку это произошло сразу после того, как я применил указанную выше команду, я протестировал ее, снова выключив, и теперь она снова работает. И, как и ожидалось, вернулись и другие ошибки. Так что я в тупике. Кто-нибудь знает, почему соединение внезапно сбрасывается при включенной этой опции?

Сбрасываемый URL выглядит следующим образом: http://www.siteurl.com/wp-admin/post.php?post=19&action=edit

Это web.config для обратного прокси-сайта:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <rewrite>
            <rules>
                <rule name="ReverseProxyInboundRule1" stopProcessing="true">
                    <match url="(.*)" />
                    <action type="Rewrite" url="http://192.168.111.15:8080/{R:1}" />
                    <serverVariables>
                        <set name="HTTP_X_ORIGINAL_ACCEPT_ENCODING" value="[HTTP_ACCEPT_ENCODING]" />
                        <set name="HTTP_ACCEPT_ENCODING" value="eee" />
                    </serverVariables>
                </rule>
            </rules>

            <outboundRules>
                <rule name="ReverseProxyOutboundRule1" preCondition="ResponseIsHtml2">
                    <match filterByTags="A, Form, Img" pattern="^http(s)?://192.168.111.15:8080/(.*)" />
                    <action type="Rewrite" value="http{R:1}://www.siteurl.com/{R:2}" />
                </rule>
                <preConditions>
                    <preCondition name="ResponseIsHtml2">
                        <add input="{RESPONSE_CONTENT_TYPE}" pattern="^text/html" />
                        <add input="{HTTP_HOST}" pattern="siteurl.com" />
                    </preCondition>
                </preConditions>
            </outboundRules>
        </rewrite>
    </system.webServer>
</configuration>

1 ответ

up 0 down accepted

Я только что решил проблему! Ответ был найден здесь: https://forums.iis.net/t/1210664.aspx

Я значительно увеличил порог буфера ответов (в разделе Маршрутизация запросов приложений -> Настройки прокси-сервера), и страницы, с которыми у меня были проблемы, начали работать сразу. Так что это была проблема, связанная с IIS.

Я надеюсь, что это поможет кому-то еще, так как это было несколько дней для меня!